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Processing your data with MAIA MultiCam Stitcher PRO 
 

This guide assumes that you have downloaded all of your multispectral files and images from your MAIA camera. If you 

have not, do so now. 

• Make a directory with your un-processed files at the start of this process. Leave this alone – this is the master copy 

and can be used for reference post-process, or if anything during processing goes wrong 

• Make a directory with a copy of your files for processing. 

• Ensure you have all the files that were on your MAIA, including settings and config files. 

 

Install MAIA’s proprietary software, MultiCam Stitcher PRO (MSP). This will have been included with the files that were 

supplied with your loan of the MAIA from FSF. If you do not have these files, please contact the FSF.  

This is a JAVA based application, and so you will also need to download and install the latest JAVA packages. The 

program is a JAVA executable file, and by default will look like this:  

 

Open the program by double clicking this icon - . For best practice, while the workstation is processing, do not 

use if for other tasks or processing. A normal processing run can be multiple hours, so a dedicated workstation is 

recommended. 

 

Figure 1 - The MultiCam Stitcher Pro home screen 

Previewing Images 
Before we start processing, it can be useful to look at your RAW images. In order to do this, click on the furthest right 

of the top buttons, ‘Preview Raw Images’ 



 
Processing Guide 

Page 3 of 25 
 

 

Figure 2 - Preview Raw images 

This will open a file browser window. Navigate to your folder with your copy of all your MAIA files for processing, and 

press ‘Select Folder’. A new window will now open. 

 

Figure 3– RAW image preview and controls 

In order to navigate though your Images, use the left and right arrow keys on the keyboard to cycle through the 

images in the image folder. You cannot navigate to a particular image using the Raw image preview, only cycle through 

images in a folder in sequential order. If you need to look at a particular image or sub-set of images, copy these into a 

different folder and navigate here initially. 

The RAW image will start on a specific sensors image;  each corresponding to a multispectral band. This is displayed in 

the image information as a suffix – S1 is sensor 1, S2 sensor 2, and so on. The image above is S8 – sensor 8. To see the 

waveband that this applies to, consult the MAIA manual. Click on the arrows at the top left and right of the image to 

navigate to the previous / next sensor image. 

 

 

Processing Chains 
This FSF field guide is in development, so at this point it only covers processing without an ILS, and with a calibrated 

white panel. 

In this processing chain, we will be using the first three buttons in MSP.  

 

Previous Sensor 

 

Next Sensor 

 

Current image Information 

> 

Right Arrow Key 

Next Image 

< 

Left Arrow Key 

Previous Image 
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Figure 4 -  Buttons for Calibration. 

Click on the first button, ‘Create M-Layer Tiff’. The panel below will open. 

 

Figure 5– Create M-Layer Tiff 

 

Firstly, select the folder which contains your images to be processed. Select the processing that you need: 

Undistortion:  Geometric correction and generation of ‘undistorted’ images through the calibration 
parameters that are included with each sensor 

Coregistration: (or Stitching) based on a reference image for image stitching of each band, with pixel-
by-pixel convergence 

Radial Correction: Corrects the border effects of the image (usually darker pixels) that can arise due to 
lens curvature. 

GPU This option uses your workstation’s GPU for processing. However, this option is very 
buggy, and we recommend you leave it unchecked to prevent fatal freezing. 

 

Once you have selected your files, a number of new options become available in the drop-down menu for 

‘Radiometric’ correction. 

Select Image Folder 



 
Processing Guide 

Page 5 of 25 
 

 

Figure 6 - Radiometric Processing options 

Processing with a Calibrated White Panel 
We are going to use the ‘White’ option, to use a calibrated white reference panel to radiometrically correct our 

images. Select WHITE. 

We are now prompted to select our ‘White paper raw image’. This is the image that you took in the field, with the 

white panel at the centre of the image. If you do not know which image this is, go back and use the ‘Preview Raw 

Image’ feature. Note – you can keep the ‘raw image preview’ window open while processing to help find white panel 

images. 

Select your white paper raw image, and press ‘Open’. 

 

Figure 7 - White Panel Reflectance Values 

The next step is to input your white panel reflectance values for each MAIA waveband. These will have been provided 

with your loan from FSF. If you cannot find these, contact FSF and we will provide you with references to your specific 

calibrated white panel. 

Click on ‘RUN’. The processing window will appear. This will now work through your images and will place the 

corrected images in a folder within your data processing folder. The folder will be named following the processing 

steps that you have undertaken, for example, this one was named ‘geom+stitch+radio+radial’. 
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Figure 8 - Maia Processing window 

 

Once this is completed, the Processing Window will disappear.  

 

Next, select ‘Crop M Layer Tiff’. This trims the edges of our processed images, to ensure there are no ‘no data’ areas 

resulting from the sensor alignment stage. 

Select the folder of your processed images. The stitch process has added a new text file to your processed folder with 

the dimensions required for a clean crop (borders.txt). This will automatically be loaded into the crop settings. 

 

Figure 9 - Crop M-Layer TIF settings 

Once this is complete, you will get a confirmation: 

 

Figure 10 - Crop confirmation 
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The cropped images are now in a new folder - geom+stitch+radio+radial_cropped. 

 

Our last stage is to get our files ready to be imported and read by other photogrammetry software.  

Select the ‘Create View’ button.  

 

Figure 11 - Creating an exportable TIFF 

Select the cropped image folder. Then, select the ‘Multichannel’ option, and ensure that all 9 channels are selected. 

Select a suitable output location, Then, press RUN. 

Once this is done, you will have you images ready to open in the software of your choice. 
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Stitching your images in Agisoft Metashape 
 

The below offers a very brief overview of the workflow for processing images in Metashape. More information and 

troubleshooting can be found at the informative Metahape turotirals and user manual: 

Tutorial: https://www.agisoft.com/support/tutorials/ 

User manual: https://www.agisoft.com/pdf/metashape-pro_1_5_en.pdf  

Open Agisoft Metashape. Navigate to Workflow, then ‘add photos’ 

 

Figure 12 - Metashape Workflow 1 

Navigate to the output of your ‘create view’ processing from MultiCam Stitcher Pro, and select all the photos you 

require to be stitched. You will then be presented with the following window: 

 

Figure 13 - Metashape 2 
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Ensure that you select the option ‘Multi-camera system’. Press OK. 

We now need to import our GPS references into Metashape.  

Navigate to the ‘reference’ window in Metashape 

 

Figure 14 - Metashape 3 

Then, click on ‘import reference’ 

 

Figure 15 - Metashape 4 

In the file options, select ‘APM/Pixhawk Log .log’  
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Figure 16 - Metashape 5 

It may be that you can’t import your files as .log – in which case, change the file extension to .csv and import with the 

same method, choosing .csv as your extension. Next, open this file in excel, and go to the ‘find and replace’ function.  

 

Figure 17 - Find and Replace in Excel 

Input ‘.raw’ in the find, and ‘.tif  in  the ‘replace with’ field. Hit Replace All, then save the file. 

In the case that you import as CSV, you need to tell Metashape which columns have the correct data. Metashape will 

prompt you with the following dialogue box: 

 

Figure 18 - Correct CSV import into Metashape 

In this  case, I need to change each of the inputs to be in the correct place. MAIA uses the Omega, Phi, Kappa system 

for rotation angles, and so this should be selected.  

Gyro X [Â°/s] = OMEGA 

Gyro Y [Â°/s] = PHI 

Gyro Z [Â°/s] = KAPPA 
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You can right click on each column, and select the correct variable from the dropdown. 

 

Figure 19 - Selecting data input in Metashape 

 

Once completed, your images should have metadata alongside them: 

 

Figure 20 - Image metadata in Metashape 

Next, we can start to process our images. In Metashape, go to workflow -> Align Photos. 
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Figure 21 - Align Photos 

Select high accuracy. Leave other boxes unchecked. Press OK.  

Next, navigate back to your workspace: 

 

 

Figure 22 - Metashape Workspace 

 

You should see that all your images are aligned: 

 

Figure 23 - Image Alignment Confirmation 

If you still have some images that are not aligned, re-run the steps above, selecting a higher accuracy. This should be 

faster as most images should have aligned.  

Next, go Workflow -> Build Dense Cloud 
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Figure 24 - Build Dense Cloud 

Hit OK.  

Hit OK. This should take up to an hour. Note that the time left may increase! 

 

Figure 25 - Processing Window 

Next, click workflow -> Build DEM 

 

Figure 26 - Build Mesh 

This should be reasonably quick (a few minutes) 

Then, go to Workflow -> Build DEM 
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Figure 27 - Build DEM 

 

Figure 28 - Build DEM 

 

Press OK. This should take around 5 minutes 

Finally, go to Workflow ->Build Orthomosaic. Ensure that ‘DEM’ is selected under ‘surface’ 
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Figure 29 - Build Orthomosaic 

 

Click OK 

This can take from 10 minutes up to an hour depending on the size of your image and complexity of textures. 

Once it is done, locate the orthomosaic in the Workspace, and right click on it, then select ‘Export Orthomosic -> 

Export JPEG /TIFF /PNG 
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Figure 30 - Export Orthomosaic 

In the following dialog box, leave all options as they are, except the following: 

▪ TIFF compression: none 

▪ Write tiled TIFF: checked 

Then press export, and select a file location. Then, that’s you done! 
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Figure 31 - Export Ortho Options 
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Converting MAIA TIF values to Reflectance 
 

Checking BIT Depth 
 

Firstly, check what the bit depth of your output files are. By default, this will be 16bit, but it is imperative you check. 

Locate one of your output files in file explorer, right click, and select properties. 

Then, navigate to the third tab, details, and scroll down to the image subsection. 

 

Figure 32 – Image properties 

This will show you this images Bit depth.  

Bit depth allows us to convert from digital number, DN, to reflectance if we know what the maximum and minimum 

values of our bit can be.  

In a 16-bit image, each pixel can have a value of 0 to 65535 

In an 8-bit image, each pixel can have a value of 0 – 255 

So, we need to scale our image so that a pixel has a value of 0 – 1, which will then be our calculated value of 

reflectance. To do this, we need to run a function within ENVI. 
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Adjustment of Scale in ENVI: 
Open your exported and stitched TIF in ENVI: 

 

Figure 33 – Imported TIF in ENVI 

If we open a spectral profile by clicking on the  Spectral profile button (or press alt+z), we can see that our image 

data is in DN. As I’ve just described, each pixel can have a value of up to 65535 for 16-bit images. We’re now going to 

scale this so that it is equal to reflectance for this TIF. 

 

Figure 34 - DN values in our TIF image 

Your image might look quite ‘jazzy’ until you change RGB bands. 

Navigate to it in the Layer Manager and right click. 



 
Processing Guide 

Page 20 of 25 
 

 

Figure 35- Changing RGB bands 

Select ‘Change RGB Bands…’ from the menu, and click on layers 4, 3, 2 in that order. This will select layer 4 as Red, 3 as 

Green, and 2 as Blue. Click ok. 

This will improve your image, but it will look even better after the next step. 

Navigate to the ‘Stretch Data’ tool, and double click 

 

 

Figure 36 – Select the Stretch Data tool in the toolbox 

 

Firstly, select the dataset to work on. Select your TIF from the input file list, leave all the other parameters as they are. 
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Figure 37 – Select your TIF from the input file list 

This will open the ‘Data Stretching’ dialogue window. The image below shows the setup for a 16bit image.  

▪ Stretch Type: Linear 
▪ Stretch Range: by value. Min 0, Max 65535 (or max 255 if 8 bit) 
▪ Output Data Range: Min 0, max 1  
▪ Data Type: Floating point. 
▪ Output Results: File. Choose a suitable output location. 

 

Figure 38 - Data Stretching 

Click OK. You will see the progress window open: 



 
Processing Guide 

Page 22 of 25 
 

 

Figure 39 – Data Stretching progress 

This will take some time depending on your file size. My 4.3GB TIF file took around 5 minutes to process on the FSF 

workstation, to produce a ~6GB ENVI file. 

Once this is done, click on the  Spectral profile button (or press alt+z) to look at the ‘stretched’ dataset. You should 

see that the scale is now 0-1. You should also find that the image looks more like what you might expect from a RGB 

camera. 

 

Figure 40 - New Spectral Profile 

This is your data converted to reflectance values. You can now adjust these values using a ground targets and the 

empirical line method detailed below. 
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Empirical Line Correction of MAIA data in ENVI 
Adapted courtesy of Dan Clewley, NEODAAS, Plymouth Marine Laboratory 

 

Step one: if you haven't already, process the output images into a stitched image using Agisoft Metashape / another 

photogrammetry software. This will use the logged GPS locations to match pixels in adjacent and overlapping imagery 

to produce an orthorectified multichannel mosiac.Once the mosaic is open in ENVI, if the colours look strange, 

navigate to it in the Layer Manager and right click. 

 

Figure 41- Changing RGB bands 

Select ‘Change RGB Bands…’ from the menu, and click on layers 4, 3, 2 in that order. This will select layer 4 as Red, 3 as 

Green, and 2 as Blue. Click ok. 

Applying Empirical Line Correction in ENVI 
With the image Window still open from the previous section select “Tools” > “Region of Interest” >“ROI tool” from the 

image menu. The ROI tool is used to identify the pixels for each target. 

1. With the image Window still open from the previous section select “Tools”> “Region of Interest” > “ROI 

tool” from the image menu. 

2. The ROI tool is used to identify the pixels for each target. 

a) From the ROI window select “Window:” “Zoom”, so only pixels clicked in the Zoom window are 

recorded. 

b) Select “ROI_Type” > “Point”, this allows you to select individual pixels rather than drawing 

polygons, which is better for small features. 

c) Select “Region #1” in the ROI list and rename to “White” by double clicking on the name, press 

“Enter” once you have renamed. 

d) In the zoom window select pixels from the centre of the white target by clicking on them. It is 

important to select pixels towards the centre to avoid mixed pixels towards the edge of the 

target where the spectra will be a mixture of the target and the surface it has been laid out on. 
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If you make a mistake you can remove a pixel using the middle mouse button (press on the 

scroll wheel). 

e) After a ROI has been defined for your first white panel, select “New Region” from the ROI 

window and repeat for any other white panels in the image. 

 

 
Figure 42 - Selecting pixels for White target using ROI tool. 

3. Once an ROI has been defined for each target save these using “File” > “Save ROIs” from the ROI 

window. Use “Select All Items” and use the “Choose” button to navigate the directory you are working in.  

4. You can view the variation in spectra within each of the targets by clicking selecting an ROI and clicking 

the “Stats” button. By default it will show the mean (white) +/- 1 standard deviation (green) and min/max 

(red), you can change using “Select Plot”. 

5. After the ROIs have been identified the empirical line calibration can be performed. 

a) Select “Spectral” > “Pre-processing” > “Calibration Utilities” > “Empirical Line” > “Compute 

Factors and Calibrate” from the main menu, or search for ‘empirical’ in the toolbar. 

b) Select “your_tiff_file.tiff” as the input file. 

c) For “Data Spectra” select “Import Spectra” then 'Import” > “from ROI/EVG from input file”. 

Select all items (White, Grey and Black), click “OK” followed by “Select All” and “Apply” to load 

into the Empirical Line dialogue, the import window can then be closed. 

d) For “Field Spectra”, we need to create a csv file for each of our white panels that were sampled 

in the field with a field spectrometer. This would have been done at the same time as the MAIA 

image was taken, typically one at the beginning and end of the image acquisition. 

i. Create a simple CSV with your spectra in excel, with wavelength in the first column, 

followed by the field reflectance values for each wavelength. Keep the first row for 

filenames, such as ‘start panel’ and ‘end panel’ for ease.  Ask FSF if you require a sample 

CSV file. 

ii.  Select “Import Spectra” then “Import” > “from ASCII”. Use the “Open” dialogue to open 

a ASCII (csv). Navigate to the directory and select “your_field_ref.csv”.  

iii. In ‘Y scale factor’, insert ‘100’, and choose ‘nanometres’ as the Wavelength Units Select 

all items and click OK, then “Select All” and “Apply” to load into the Empirical Line 
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dialogue, the import window can then be closed. 

e) Select matching pairs of data in the “Data Spectra” box and the “Field Spectra” box (eg to match 

your ROI to the correct field measurement,  and click “Enter Pair” to identify them as a matching 

image spectra and field spectra pair. Repeat for the other targets then click “OK”. 

 
Figure 43 - Selecting Pairs in ENVI Empirical Line Correction 

 

 

6. Once the Empirical Line Correction has finished a new file will appear in the layer manager window. 

Right click on this and select choose RGB bands if required. 

7. Within the Image window menu for the new file select “Tools” > “Profiles” > “Z Profile (Spectrum)” to 

bring up the spectral profile window and use this to view the spectra. The values are reflectance and go from 

0 – 100, There are likely to be noisy regions of the spectrum where reflectance is recorded as being negative, 

these can be removed as part of post processing if required. 

 

 


